主頁spacer>軟體支援>Mergemill Pro 快速入門指南

spacer

學習使用 Mergemill Pro 的一個好辦法,就是逐步觀察它的運作過程。安裝的軟體包巳包括一個簡單的例子:Mergemill Pro > Mergemill Resources > Examples > 繁體中文 > 簡單案例。此外,這兩篇重要文章也值得一讀:Mergemill Pro 的連接設定有關文本編碼的一些須知


概覽

Mergemill 將模板的靜態內容與數據饋送合併生成你想要的輸出。你在模板中嵌入特殊標籤,指定如何從饋送中插入內容。

模板內類似 <?[佔位欄名稱]?> 的標籤主要以插入內容為目的。所有放置於對應的 <?Loop?> 及 <?EndLoop?> 標籤之間的佔位欄屬於「循環內佔位欄」,其餘的為「循環外佔位欄」。數據饋送內容插入佔位欄可直接插入提取之數據值,或插入動態生成的數據值。

當你在 Mergemill Pro 設定一個合併作業,你須指定一個相關的模板,並按下一個按鈕來解析它。在模板中發現的每一個新的佔位欄名稱,Mergemill Pro 會自動為其在相關作業之下添加一個任務定義,讓你設定該佔位欄自數據饋送提取內容的數據列,或指定數據值是如何動態地生成。

當你運行一個作業,其相關模板會被重複執行,直到用盡所有主要的數據饋送。模板每次運行時,Mergemill Pro 將模板中的所有靜態內容複製到輸出,並從指定的數據源提取相應的數據值來取代每個佔位欄,生成完整的輸出。視乎你設定的作業輸出選項,當 Mergemill Pro 達到模板的終結,便會生成下列一個輸出:合併後的文本轉換成語音、群發自定義的合併電郵、合併後的文本儲存為文檔、使用合併後的數據來更新 SQL 數據源、或匯出數據到 CSV 或 XML 文檔。


啟動

Mergemill Pro 啟動後,主視窗便會出現。視窗的標題顯示當前 Mergemill 文件的名稱。

要啟用 Mergemill Pro 的所有功能,你需要在「偏好設定」視窗內輸入有效的軟體授權密鑰。要顯示「偏好設定」視窗,在 Mac 上可選 Mergemill Pro > Preferences... 選單項目,在 Windows 上,可選 Help > Preferences... 選單項目。如沒有一個有效的軟體密鑰,Mergemill Pro 運行時將有以下限制:

  1. 每個佔位欄只會使用最多 50 個數據值。
  2. 專案的自動運行功能只運作一小時。
  3. [匯入...] 按鈕停用。
  4. 每個新建 Mergemill 檔案只容許 [運行專案] 及 [運行作業] 按鈕被使用 30 天。

請注意:未經授權的 Mergemill Pro 軟體會通過讀取在我們網站的日期字符串來監察 Mergemill 文件的有效期。除了這一小塊數據的請求被群發到我們網站,絕對沒有其他的數據傳送。巳被授權密鑰激活的 Mergemill Pro 除獲取我們的在線文檔和檢查軟體更新外,不會與我們的網站聯繫。


輔助選單項目

要了解每個用戶界面元素的用途,可選擇 Mergemill Pro 選單項目:「輔助說明 > 顯示輔助提示」。如要快速查找標籤語法,你可選擇選單項目:「輔助說明 > Mergemill 標籤指南」及「輔助說明 > 正則表達式指南」。


用戶界面的輸入控制

當你輸入或指定設定值時,用戶界面的元素和頁面會被適當地啟用和禁用,以免你因無關的物件而分心。例如,只有當你選擇了專案作業列表上的一項作業,作業設定的頁面才會被激活。同樣,只有當你選擇了作業任務列表上的一項任務,適當的數據饋送設定頁面才會被啟用。


紅點除錯導引

Mergemill Pro 的功能設計是要讓用戶輕易建立複雜的作業和其相關任務。一個例子是其「紅點系統」,以提醒你在作業和任務設定的錯誤。只要按照紅點逐一修復,你便可輕鬆地創建有效的作業定義。這使你可以專注於模板設計,創造有效的解決方案,解決實際問題。


Mergemill 模板

一個 Mergemill 模板包含要輸出的所有靜態文字,再加上 Mergemill Pro 要執行的指令標籤。你當用一個簡單的文本編輯器或 Adobe Dreamweaver 來創建或編輯模板,而不應使用類似 Microsoft Word 的軟體應用程式,因為後者嵌入了隱藏的字符,令你的模板內看似正確的 Mergemill 標籤實際上是 Mergemill Pro 無法識別的。

創建模板時應緊記所有佔位欄標籤皆會插入內容,無論是動態生成或從數據饋送讀取的,整個處理模板的結果將是相關作業的輸出。也請記住,所有作業和任務設定中的過濾、數據處理、查找替換及排序動作皆會在運行模板之前被應用到讀取的數據值。

如果你編輯當前模板和再次解析它,一些佔位欄可能已被刪除或其名稱已被更改。Mergemill Pro 不會自動刪除這些佔位欄的任務設定,以防你需要它們作為參考,或稍後改變主意,在模板內再次使用它們。這些佔位欄名稱會被加插「X:」作為標記。你可隨時使用「刪除休眠中的任務」按鈕來刪除這些佔位欄任務設定。Mergemill Pro 運行作業時會略過所有處於休眠狀態的任務。


生成靜態網頁的工作流程

  1. 工作流程應盡量有條理。先在「作業」檔案夾內創建「模板」、「數據源」及「輸出」子檔案夾。
  2. 創建模板:
    • 製作一個樣本網頁,作為一個具體的輸出目標,並將其複製到「模板」檔案夾。
    • 決定哪些數據元素將被插入到網頁內,以 Mergemill 佔位欄標籤取代那些部分,如 <?[城鎮名稱]?>,以便由數據源提供內容。
    • 加入其他所需的指令標籤,如 <?Loop?>...<?EndLoop?> 及 <?If(...)?> 等,以控制如何將數據值插入。
  3. 將輸出所需的輔助檔案,如 GIF 圖像,複製至「輸出」檔案夾內。Mergemill Pro 會自動創建輸出文檔路徑中所有非現有的子檔案夾,但你必須確保在生成的網頁內所有超連結的正常運作。
  4. 添加一項作業,並指定修改後的樣本網頁為模板,然後按一下 [解析模板內容] 按鈕。於模板中發現的每一個新佔位欄標籤名稱,Mergemill Pro 會自動為其在當前作業內添加一個任務定義,讓你可指定每個佔位欄標籤應從哪個數據饋送的哪個數據列提取內容,或指定數據值是動態生成的。
  5. 測試運行作業。Mergemill Pro 會讀取數據值,進行過濾、處理及查找替換的行動,然後對數據進行排序,然後它會將所有模板的靜態內容複製至你的輸出,並以適當的處理後數據值取代每個佔位欄標籤,生成輸出。
  6. 測試運行和編輯你的模板,直至達到你想要的結果。
  7. 重複步驟 2 至 6 去運行每個模板。


其他作業的工作流程

  1. 工作流程應盡量有條理。先在「作業」檔案夾內創建「模板」、「數據源」及「輸出」子檔案夾。
  2. 製作一個輸出樣本,作為一個具體的輸出目標。
  3. 用一個簡單的文本編輯器編輯模板。
  4. 添加一項作業,並指定編輯好的模板,然後按一下 [解析模板內容] 按鈕。於模板中發現的每一個新佔位欄標籤名稱,Mergemill Pro 會自動為其在當前作業內添加一個任務定義,讓你可指定每個佔位欄標籤應從哪個數據饋送的哪個數據列提取內容,或指定數據值是動態生成的。
  5. 測試運行作業。Mergemill Pro 會讀取數據值,進行過濾、處理及查找替換的行動,然後對數據進行排序,然後它會將所有模板的靜態內容複製至你的輸出,並以適當的處理後數據值取代每個佔位欄標籤,生成輸出。視乎你的作業設定,每當 Mergemill Pro 到達模板的結尾,便會產生下列其中一個輸出:將合併後的文本轉成語音、群發合併後的電郵、儲存合併後的文檔至指定位置、用處理後的數據更新 SQL 資料庫或將處理後的數據匯出到製表符分隔或 CSV 或 XML 格式的文檔。
  6. 測試運行和編輯你的模板,直至達到你想要的結果。
  7. 重複步驟 2 至 6 去運行每個模板。

spacer

返回頁首

軟體功能spacer::spacer下載專區spacer::spacer購買spacer::spacer軟體支援spacer::spacer視頻教程spacer::spacer標籤指南spacer::spacer網站導覽


版權所有 · 不得轉載 © 2001-2017 Cross Culture Ltd.